Weird gliss playback

Discussions about our next-generation scoring application, Dorico.
JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Weird gliss playback

Post by JosueViera »

I’ve unsuccessfully tried to figure out why this is happening.
In the project I’m attaching below, in flow 2, bar 136, none of the glissandi in the harp are playing back. Weirdly, another gliss in the same flow, bar 118, is playing back normally. Out of curiosity, I created a new simple gliss in bar 155. It plays back perfectly. Then I manually made an exact copy, in the next bars (156 and 157), of bars 136 and 137. Those gliss don’t play back. I manually made an exact copy, in bar 158, of the gliss in bar 158 (the last bar); that gliss doesn't play back either.
In Play mode, if I deactivate voice separation in the harp, every glissandi plays back perfectly. But when I separate voices, it reverts to the weird behavior of selectively playing only some glissandi, even if all the voices implicated are routed to the same channel.
Another semi-related issue. How can I separate voices in an instrument just for one flow? I want to separate voices in the harp because I need to use a different channel for the fourth voice; but only in flow 1. I want the rest of flows normally, in the same channel. Apparently, I have to manually set each voice to the same channel for the rest of flows.
I’m using Noteperformer, by the way.
Any insights?
Attachments
Example.dorico.zip
(1.11 MiB) Downloaded 23 times
Last edited by JosueViera on Thu Oct 31, 2019 10:56 pm, edited 1 time in total.

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

The glissandos in your project (where they are present; there's no glissando in bar 138 of the second flow, as far as I can see, for example) seem to play back OK for me. If you're using independent voice playback, I would suggest you make sure the glissando is attached to notes in the same voice at both ends, even if those notes need to be on the other staff.

You can't have independent voice playback for just one flow in your project, but what you should find is that if you have the "Set for all flows" button chosen, Dorico will do its best to map corresponding voices in each flow to the same endpoint if possible.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

My bad! It’s bar 136, not 138. [I just edited the first post correcting it.]
Is there something in my configuration that messing these bars? Because the other glissandi work just fine. Also, they are in the same voice each, so that shouldn’t be a problem.

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

The glissandos in bar 136 all play back for me.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

So it’s something in my settings or environment. Any suggestion so I can pinpoint the problem and solve it?

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

I'm afraid not at the moment, no, but if I do think of anything I'll let you know.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

It’s happening with this project too. Bar 38 doesn't play gliss. Bars 60 and 133 play back all right.
Attachments
Example 2.dorico.zip
(929.44 KiB) Downloaded 13 times

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

Make sure you create an appropriate harp pedal change (e.g. using Write > Create Harp Pedaling) so that Dorico knows what the pedal settings are. If you switch on View > Note and Rest Colors > Notes Out of Range you'll see lots of the notes in the harp part are red, because Dorico is assuming the pedals are all set to naturals, which makes E flat major unplayable.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Oh, I forgot to copy the pedal changes. But that doesn’t explain why the other gliss do play back fine. Anyways, I just created the pedal changes and it is still not playing that specific glissando. All the others play normally.
Last edited by JosueViera on Mon Nov 04, 2019 10:06 am, edited 1 time in total.

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

The pair of glissandos in bar 38 play back just fine for me after a pedal change has been inserted.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Agggghhhh! This is really driving me bonkers. I can’t find what is it that’s affecting on my side but doesn’t carry on to your side through the file. It’s obviously an issue in my environment and my settings.

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

Yes, I'm sorry I'm unable to provide a solution for you. If you copy and paste that passage to a harp instrument in a newly-created project and add an appropriate pedal change, do you find that it plays back there?

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Ok, here’s exactly what I just did with its respective results:
1. Created a new project. Added Harp. Added 4/4. Added Eb major key. Set the tempo to q = 60. Copied and pasted the aforementioned passage (exclusively the three bars) from the old project. Created the harp pedal change. Pressed play. … Everything plays just fine, including the glissandi.
2. In Play mode, I toggled on the option to separate voices in the Harp. Pressed play. … Now the glissandi don't play back.
3. Re-routed all voices to the same channel. Pressed play. … Still no gliss. playback.
4. Toggled off the separating voices option. Pressed play. … Now everything plays normal again, including the gliss.

As a side note, the glissandi go from notes to notes of the same voice. I even tried leaving them in the same staff (even though it looks horrible), but still the gliss. don’t play back if the voice separation option is on.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Hey, I just discovered something curious.
In the new project mentioned in the post above:
1. I added a new bar using the system track.
2. Created a new simple gliss in the treble clef, from a C6 to a G4 (random notes), using quarter figures.
3. Then, I created another new simple gliss, still in the treble clef, from an Ab5 to a Eb4 (also random notes). I wanted to see if they would play back.
4. Pressed play. … The first glissandi (the ones mentioned in the post above) still didn't play back, but the newly created gliss. behaved different each: the first one, from C6 to G4, played back correctly; the second one, from Ab5 to Eb4, didn't play back at all. This behavior drew my attention. I couldn't see the difference between those two gliss. Why would one play, but not the other?
5. I swapped both glissandi, to see if it had to do with their rhythmic position. It didn't. Still the Ab5–Eb4 didn't play, but the C6–G4 did. Then it hit me: one had accidentals while the other didn't.
6. I changed the starting note of the gliss. not playing (Ab5-Eb4), from Ab5 to G5. Then I changed the end note from Eb4 to D4.
7. Pressed play. … Both glissandi played back perfectly!
8. I went further testing this new suspicion. I changed the gliss. back to Ab5-Eb4. It didn't play back.
9. I changed only one note. G5 instead of Ab5. No playback. D4 instead of Eb4. No playback.
10. I tinkered around trying many kind of gliss. Upwards, downwards, from voice 1 to voice 2, crossing staves, slow gliss., fast gliss., short ones, long ones. Every single one of them played back normally as long as it didn't start or end in an accidental, either from the key signature or inserting it in the bar (even if the pedal changes are correctly in place).
8. I went on to test this new theory, and changed the original glissandi (post above). Both start in the perfect fifth Ab/Eb and rise to that same fifth, six octaves higher. Changed the fifth to G/D. They now play back perfectly.

I hope this somehow (no idea how) helps to pinpoint what is going on with my system.

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

Dorico won't play back a glissando on harp unless there is a valid harp pedal change present. In particular, the starting and ending notes of the glissando must be playable according to the current harp pedal settings for Dorico to be able to play back the glissando.

Regarding using independent voices for the harp, I wonder why you need to do this? Is it because NotePerformer doesn't correctly handle dynamics for percussive instruments like piano? If so, I believe this will be addressed in the forthcoming NotePerformer 3.3 update.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

The thing is there IS a valid pedal change present. If I activate color for out-of-range notes, there are no red notes. But still, the glissandi with accidentals in the start or end note are not working.

Regarding the use of independent voices for the harp, it’s because, right now, I use Noteperformer, and it doesn't include some effects (like percussion on the soundboard), so I use a different voice for the notation and re-route the voice to a channel where I can override the harp sound and assign a percussion sound (hand drum, for example). Also, sometimes I need a strumming-with-nail effect that has a very different dynamic than normal playing, so I have to manipulate the channel volume independently.

wader
New Member
Posts: 13
Joined: Thu Nov 26, 2015 9:25 pm
Contact:

Re: Weird gliss playback

Post by wader »

Hi JosueViera,

Were you able to find a solution to this? In my current project no harp glisses play back, although my harp instrument is connected and I can play it with my midi keyboard. I've tried separating the voices, generating pedal diagrams for the whole part and checking for notes outside their ranges. I have no red notes and everything looks correct.

Thanks,

Robin

wader
New Member
Posts: 13
Joined: Thu Nov 26, 2015 9:25 pm
Contact:

Re: Weird gliss playback

Post by wader »

I worked it out. In my case I was using Spitfire BBCSO harp and the expression maps provided by Spitfire within their Cubase Template. The thing that resolved the issue was to add a 'Natural' technique in the expression map and give it the appropriate keyswitch data.

I hope this helps!

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Thank you wader, I’m going to tinker with the expression map to see if anything comes up. I’ll be posting any findings.

JosueViera
Junior Member
Posts: 157
Joined: Sat Feb 25, 2017 12:39 am
Contact:

Re: Weird gliss playback

Post by JosueViera »

Daniel at Steinberg wrote:
Mon Nov 04, 2019 10:12 pm
Dorico won't play back a glissando on harp unless there is a valid harp pedal change present. In particular, the starting and ending notes of the glissando must be playable according to the current harp pedal settings for Dorico to be able to play back the glissando.
Daniel, that IS true. But in my case, when voice separation is activated, it’s as if the pedal changes are not recognized and the harp setting remains with all notes natural (but only in playback, because out of range coloring of notes still works fine).

I’m sharing a screen capture where I:
1. Start a completely new project, add Harp, create a gliss from C4 to C6. Playback normal.
2. Make the Cs sharp. No playback (as expected).
3. Add a pedal change. Playback normal (as expected).
4. Separate voices. Here starts the weird behavior. No playback.
5. Change the Cs to Ds or Fs (random natural notes). Playback normal.
6. Change back to C natural (and here is the catch; the pedal change is indicating a C#, not a C natural). The gliss plays back! Even when the notes are not playable according to the harp pedal setting (they are even colored red). The gliss SHOULD NOT play back; but it plays back because they are natural.
7. Turn them sharp again, they don’t play back (they SHOULD play back).

So, something in voice separation must be messing with pedal changes. And apparently it’s something local. Does this help to pinpoint the problem?

Screen capture: https://we.tl/t-fVUhqASfBf

Derrek
Grand Senior Member
Posts: 3568
Joined: Sun Aug 07, 2016 6:23 pm
Location: East Coast, USA
Contact:

Re: Weird gliss playback

Post by Derrek »

How is harp glissando handled behind the scenes? Does Dorico generate every note based on the pedal diagram or send some keycode that might be specific to HALion (or GM) that runs the gliss?
Dorico Pro 3.5.0.1020, Finale (v26), GPO, JABB3, GWI, NotePerformer 3, CuBase Pro 10.5 newbie
Windows 10 (also Mac Catalina as alternate)
US English Keyboard

Rob Tuley
Grand Senior Member
Posts: 3636
Joined: Fri May 20, 2016 12:41 am

Re: Weird gliss playback

Post by Rob Tuley »

By default it generates the notes. In fact you can change the pedal settings in the middle of a glissando if you want (just like on a real harp).

It's certainly not specific to HALion, it works fine with NotePerfomer. General MIDI just thinks the harp is a chromatic instrument like everything else, and doesn't "know" anything about the pedals.

Of course with sample libraries somebody always thinks of a creative way to make life difficult. For example the Garritan Harps library has a set of key switches to map the MIDI notes of the "white" keys to different pedal settings, so you can easily play harp glissandos "live" from a MIDI keyboard. Probably the easiest way to use that option in Dorico is just ignore it completely :)

Derrek
Grand Senior Member
Posts: 3568
Joined: Sun Aug 07, 2016 6:23 pm
Location: East Coast, USA
Contact:

Re: Weird gliss playback

Post by Derrek »

Yes, I'm familiar with the Garritan Harps and have expressions set up in Finale to position the switches, but I doubt I'll use the Garritan Harps in Dorico any time soon, at least not until I know a lot more about Expression Maps and Playing Techniques.

Thank you, Rob, for the info.
Dorico Pro 3.5.0.1020, Finale (v26), GPO, JABB3, GWI, NotePerformer 3, CuBase Pro 10.5 newbie
Windows 10 (also Mac Catalina as alternate)
US English Keyboard

User avatar
Daniel at Steinberg
Moderator
Posts: 17434
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Weird gliss playback

Post by Daniel at Steinberg »

Josue, if you're going to use independent voice routing with the harp and want to write glissandos that start on one staff and end on the other, make sure that the starting and ending notes are in the same voice.

Rob Tuley
Grand Senior Member
Posts: 3636
Joined: Fri May 20, 2016 12:41 am

Re: Weird gliss playback

Post by Rob Tuley »

You mean Dorico playback isn't clever enough to automatically cross fade the gliss from one voice routing to the other?? :twisted:

(Only joking, of course).

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: dankreider, dwlarson, GregS, mducharme, mmka and 13 guests