Cubase 10.0.20 maintenance update

Post general topics related to Cubase Pro 10, Cubase Artist 10 and Cubase Elements 10 here.
User avatar
Matthias Quellmann
Moderator
Posts: 810
Joined: Tue Mar 01, 2011 9:44 am
Location: Hamburg, Germany
Contact:

Cubase 10.0.20 maintenance update

Post by Matthias Quellmann » Wed Apr 17, 2019 12:40 pm

This is the latest maintenance update for all Cubase 10 versions. In addition to several fixes, 10.0.20 includes improvements for the color handling, the context menus, the hitpoint detection and other areas within Cubase 10. A number of plug-ins have been updated to include updated graphics for high resolution displays... some of them even have had a complete re-design. Our tip: check out the updated ModMachine!

Download and version history
Matthias Quellmann - Senior Marketing Manager
Steinberg Media Technologies GmbH
Hamburg, Germany
Checkout Steinberg on YouTube, Twitter and Facebook!

arieln
Junior Member
Posts: 92
Joined: Thu Jun 08, 2017 7:55 am
Contact:

Re: Cubase 10.0.20 maintenance update

Post by arieln » Wed Apr 17, 2019 1:22 pm

Thanks so much Matthias, working great so far!
Cubase Pro 10.0.10 (Build 100) / Windows 10 64bits

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Prock » Wed Apr 17, 2019 1:23 pm

Thanks for the update. Installed easily and seems to be working good.

However, it did not install the current latest eLicenser control center version (6.11.6.1249) which, I was told, maintenance updates would always do.

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

Ambientdave
Member
Posts: 247
Joined: Mon Jun 11, 2018 11:17 am
Location: Hampshire UK
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Ambientdave » Wed Apr 17, 2019 1:49 pm

Thank you for the update ,Matthias
Great job everyone
Windows 10 Pro, with Intel i5 340GHz, 16GB RAM, 1TB SSD,500GB HDD,external 1TB HDD,

Audio interface, Focusrite Scarlett 2i2 2nd gen,monitoring through Beyerdynamic DT250 headphones.
Microphone: Rodes NT1A
Midi controllers: Akai MPK249 and M Audio Oxygen 25,
Software: Cubase Pro 10 (latest version),various sound libraries and plugins

zipb
Junior Member
Posts: 112
Joined: Wed Dec 16, 2015 12:02 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by zipb » Wed Apr 17, 2019 2:10 pm

I don't see any mention of fixing weird behaviour in OSX10.14 aka Mojave. CB Pro 10.0.x and MacOS 10.14.4 are unusable for me. Weird crashes, file selectors that do not work, CPU load is all over the place, CB won't quit...

All other stuff is fine(Logic Pro, Lightroom, Photoshop, etc.)

MacOS 10.13.1 and any version of CB 10 are working well. But I would like to use my iPad as an EBU metering device, and the dualscreen app is working so much better with Mojave.

I will find out tonight, I guess.
Desktop:
Gigabyte Z390 Designare/i9 9900k/OSX10.14.5/Cubase Pro 10.0.30/32 GB RAM/MSI AMD R480x/SSD's/Metric Halo ULN-8/UAD2 Quad
Laptop:
MacBook Pro 8,2/OSX10.12.6/8GB RAM/SSD/Metric Halo ULN-2

User avatar
Quietly
Member
Posts: 290
Joined: Fri Dec 17, 2010 4:15 pm
Contact:

Re: Cubase 10.0.20 available

Post by Quietly » Wed Apr 17, 2019 2:13 pm

GUI problem with HiDPI selected still 100% or 200%. This means monitor set at 150% Cubase is 200%, Monitor set at 125% Cubase is at 100%. Alternative deselect HiDPI and you have a blurry GUI. What a let down.
https://soundcloud.com/gerry-cooper-855281238
Cubase Pro 10.0.40. Windows 10 Pro 64 bit. Intel Core 2 Quad CPU Q9550 @ 2.83 GHz 4GB RAM. ASUS Radeon R7-259 Graphics Card , Focusrite Scarlett 2i4. Komplete Kontrol S61 and HS80M Monitors. Komplete 10 Ultimate, Symphobia, Ozone 8 etc

peachy
Junior Member
Posts: 126
Joined: Sun Jul 24, 2011 7:13 pm
Location: Scotland
Contact:

Re: Cubase 10.0.20 maintenance update

Post by peachy » Wed Apr 17, 2019 2:42 pm

Prock wrote:
Wed Apr 17, 2019 1:23 pm
Thanks for the update. Installed easily and seems to be working good.

However, it did not install the current latest eLicenser control center version (6.11.6.1249) which, I was told, maintenance updates would always do.

Regards 8-)
I have yet another shortcut for eLicenser Control on my desktop, as I delete it every time it appears, means the update must have installed a new version on my PC. I always assumed it needed updating to have the entry in the eLicence database to recognise the version of product you have just installed. Which if you take that to its conclusion, means if Cubase starts eLicencer must have been upgraded.... I think :-)
Intel i7 8700K @4.8, Intel Z370 , 32 gig corsair RAM, Nvidia 1080, 4k monitor, Windows 10 64 bit, Steinberg UR824, Cubase 10 Pro, HALion 6, Groove Agent 5. SoundToys, U-He, NI, Moog. and 30 years of other kit....

User avatar
thermionic
Member
Posts: 356
Joined: Tue Aug 16, 2011 5:56 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by thermionic » Wed Apr 17, 2019 3:50 pm

I'm getting an installation error message:
"An installation package for the product Steinberg Library
Manager cannot be found. Try the installation again using a valid
copy of the installation package Steinberg Cubase Update"
I haven't moved or deleted any files and my e-Licenser is up-to-date, I have downloaded the update from both the Cubase forum and also the Download Manager. This is the first problem I've ever had with Cubase updates but my charmed life has come to an end :D Any ideas? Thanks in advance.

User avatar
Faramis
New Member
Posts: 26
Joined: Tue Apr 19, 2016 12:44 pm
Location: Paris
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Faramis » Wed Apr 17, 2019 4:14 pm

Quite a lot of fixes and improvements,good job Steinberg.
win10_1903/Cubase pro 10.0.30/Wavelab Element 9.5.50
Asus B450M-Plus/R7 1700X @3.4ghz/G-Skill ddr4 16gb-2133MHz /Evo 970 M.2 nvme 500gb+Crucial BX500 480gb SSD/MSI gt 710 1gb/Dell 1920x1080/
Umc202hd/Ath-m30x,AV 42,Microkey2-37

simthembile
Junior Member
Posts: 117
Joined: Fri Apr 07, 2017 1:27 am
Contact:

Re: Cubase 10.0.20 maintenance update

Post by simthembile » Wed Apr 17, 2019 4:36 pm

Working fine here as well.

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Prock » Wed Apr 17, 2019 4:44 pm

peachy wrote:
Wed Apr 17, 2019 2:42 pm
Prock wrote:
Wed Apr 17, 2019 1:23 pm
Thanks for the update. Installed easily and seems to be working good.

However, it did not install the current latest eLicenser control center version (6.11.6.1249) which, I was told, maintenance updates would always do.

Regards 8-)
I have yet another shortcut for eLicenser Control on my desktop, as I delete it every time it appears, means the update must have installed a new version on my PC. I always assumed it needed updating to have the entry in the eLicence database to recognise the version of product you have just installed. Which if you take that to its conclusion, means if Cubase starts eLicencer must have been upgraded.... I think :-)
Just to reiterate/clarify...
Cubase installs an eLicense Control Center when you apply the maintenance update. I was told that it would always install the latest version available and not install an older version over a newer version that is already on the computer. Well for me, I had the latest version of eLCC version 6.11.6.1249 installed prior to installing the CB 10.0.20 maintenance update. During that, it installed an older version 6.11.6.1248 over my newer version. I complained about this before. IMO it is lame! :roll:
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

Centralmusic
Grand Senior Member
Posts: 5369
Joined: Wed Dec 15, 2010 6:23 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Centralmusic » Wed Apr 17, 2019 5:06 pm

:o what a great update! thank you Steinberg!! 8-)
"They told us all they wanted was a sound that could kill someone from a distance" (Kate Bush, Experiment IV)
"Do you already know the manual?" ^^
Kennst du schon das Handbuch?" ^^

Centralmusic
Grand Senior Member
Posts: 5369
Joined: Wed Dec 15, 2010 6:23 pm
Contact:

Re: Cubase 10.0.20 available

Post by Centralmusic » Wed Apr 17, 2019 5:08 pm

Quietly wrote:
Wed Apr 17, 2019 2:13 pm
Alternative deselect HiDPI and....
Alternative buy another flat screen. I´m fine with 200 % and HDI in Cubase. LG 4k curved. No problems here.
"They told us all they wanted was a sound that could kill someone from a distance" (Kate Bush, Experiment IV)
"Do you already know the manual?" ^^
Kennst du schon das Handbuch?" ^^

Jim B
Member
Posts: 406
Joined: Thu May 12, 2011 9:03 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Jim B » Wed Apr 17, 2019 5:39 pm

Great update, all good so far!

Is there any information about the new Hitpoint detection? I looked at the online manual but couldn't see anything about the new detection there.
I know Greg is doing a Google Hangout tomorrow night, and I guess he will explain the nuances during the "show", but I wanted to have a little experiment by myself!

Thanks,

Jim B
Musician, songwriter, singer, guitarist, band member.
System: HP Ali-in-One 24-f0xx, Intel i3-813OU CPU @2.20GHz 2.21 GHz, Windows 10 64bit.
DAW: Cubase Pro 10.30, Focusrite 2nd gen 1818i interface, Padshop Pro, Halion Sonic 3, VST Connect Pro, PreSonus e 4.5 monitors, AKG K240 cans.
Instruments: M Audio KeyRig 49, Sigma OMT-1STE+ acoustic guitar , Washburn D20n acoustic guitar, Weissenborn lap slide acoustic guitar, Epiphone resonator acoustic guitar, Fender Deluxe Roadhouse stratocaster

Our band singles recorded using Cubase & VST Connect: https://soundcloud.com/stanhope-road

Orestis
Junior Member
Posts: 57
Joined: Thu Dec 03, 2015 12:22 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Orestis » Wed Apr 17, 2019 5:47 pm

good update so far!!

Let's hope is a good new era of "working updates" and see more and more issues to be fixed in the future.
Intel i7-5820K @ 3.30Ghz / 64GB Ram / MSI X99A Raider
Nvidia MSI GTX 1060 6gb / RME ADI-2 Pro FS + Fireface 800 + ADI-8DS
UAD 8-cores / Windows 10-64bit 1809 / Cubase 9.5.50 / 10.0.20
MacBookPro Retina i5 @ 2.4Ghz / 10.11.6 / 8GB Ram
UAD Apollo Twin Thundr.2/C

peachy
Junior Member
Posts: 126
Joined: Sun Jul 24, 2011 7:13 pm
Location: Scotland
Contact:

Re: Cubase 10.0.20 maintenance update

Post by peachy » Wed Apr 17, 2019 5:50 pm

Prock wrote:
Wed Apr 17, 2019 4:44 pm
peachy wrote:
Wed Apr 17, 2019 2:42 pm
Prock wrote:
Wed Apr 17, 2019 1:23 pm
Thanks for the update. Installed easily and seems to be working good.

However, it did not install the current latest eLicenser control center version (6.11.6.1249) which, I was told, maintenance updates would always do.

Regards 8-)
I have yet another shortcut for eLicenser Control on my desktop, as I delete it every time it appears, means the update must have installed a new version on my PC. I always assumed it needed updating to have the entry in the eLicence database to recognise the version of product you have just installed. Which if you take that to its conclusion, means if Cubase starts eLicencer must have been upgraded.... I think :-)
Just to reiterate/clarify...
Cubase installs an eLicense Control Center when you apply the maintenance update. I was told that it would always install the latest version available and not install an older version over a newer version that is already on the computer. Well for me, I had the latest version of eLCC version 6.11.6.1249 installed prior to installing the CB 10.0.20 maintenance update. During that, it installed an older version 6.11.6.1248 over my newer version. I complained about this before. IMO it is lame! :roll:
I beg your pardon, your right its v6.11.6.1248 not 1249, probably because its late....... Is it really a problem?
Intel i7 8700K @4.8, Intel Z370 , 32 gig corsair RAM, Nvidia 1080, 4k monitor, Windows 10 64 bit, Steinberg UR824, Cubase 10 Pro, HALion 6, Groove Agent 5. SoundToys, U-He, NI, Moog. and 30 years of other kit....

User avatar
Quietly
Member
Posts: 290
Joined: Fri Dec 17, 2010 4:15 pm
Contact:

Re: Cubase 10.0.20 available

Post by Quietly » Wed Apr 17, 2019 6:09 pm

Centralmusic wrote:
Wed Apr 17, 2019 5:08 pm
Quietly wrote:
Wed Apr 17, 2019 2:13 pm
Alternative deselect HiDPI and....
Alternative buy another flat screen. I´m fine with 200 % and HDI in Cubase. LG 4k curved. No problems here.
Well that's constructive. How about buying another DAW where HiDPI scaling really works which is exactly what I have done. Imagine an official statement like "All those who require HiDPI scaling at 125%, 150% and 175% go and buy another Monitor" :?
https://soundcloud.com/gerry-cooper-855281238
Cubase Pro 10.0.40. Windows 10 Pro 64 bit. Intel Core 2 Quad CPU Q9550 @ 2.83 GHz 4GB RAM. ASUS Radeon R7-259 Graphics Card , Focusrite Scarlett 2i4. Komplete Kontrol S61 and HS80M Monitors. Komplete 10 Ultimate, Symphobia, Ozone 8 etc

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Prock » Wed Apr 17, 2019 6:14 pm

peachy wrote:
Wed Apr 17, 2019 5:50 pm

I beg your pardon, your right its v6.11.6.1248 not 1249, probably because its late....... Is it really a problem?
No... it's not a problem per se. But, it should be a simple programming matter to ensure it always installs the latest one available on the website. These "little" things matter to me.

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

User avatar
vanhaze3000
Member
Posts: 259
Joined: Fri Nov 29, 2013 11:20 pm
Location: Netherlands
Contact:

Re: Cubase 10.0.20 maintenance update

Post by vanhaze3000 » Wed Apr 17, 2019 6:24 pm

Today i installed Cubase 10.0.20 maintenance update.
After opening it, immediately all kinds of E-licenser errors and eventually i had to shut down Cubase cause the errors made Cubase hang.
De-installed E-licenser software (with the de-installer that comes with it).
Downloaded newest E-licenser version from Steinberg site and installed that.
I then executed the maintenance option in E-licenser software.
Just for the sake, i logged my macbook out and then in.
I openend Cubase 10.0.20 again.
This time: no more E-licenser errors and Cubase started up succesfully.
Macbook Retina 2015 * OSX Mojave 10.14 (always latest version) * UA Apollo Twin Thunderbolt * Cubase 10 Pro (latest version) * Maschine Studio2 * Novation Impulse * Lots and lots of legal plugins.

dman2014
Member
Posts: 487
Joined: Fri Dec 27, 2013 11:17 am
Contact:

Re: Cubase 10.0.20 maintenance update

Post by dman2014 » Wed Apr 17, 2019 8:36 pm

Only thing I've noticed since installing this on my system is that Cubase now always asks whether I want to save or not on exit, even after saving the project just before. That's a bit annoying, but rattles confidence as to why it's happening.
Cubase Pro 10 | Cubase Pro 9.5 | Cubase Pro 9 | Cubase 8 Pro | Cubase 7.5.3 | Sonar X3 Studio | Komplete 11 | Windows 10 Pro 64-bit | Intel i9-9900K @ 4.9GHz | 64GB RAM | UAD Apollo Twin Mk2 Quad | iConnectivity mio | Intel i7-6800K - 4.2GHz | 64GB RAM | Window 7 Pro 64-bit | Intel i7 4770 (Haswell) - 3.6GHz | 32 GB RAM | Focusrite Saffire Pro 14 | AMD Radeon HD 6450 | UAD Plugins | Various Waves Plug-ins | Sonnox Oxford Plug-ins | Slate Digital Plug-ins | Soundtoys Plug-ins | FabFilter Plug-ins | Various other VSTs and Plug-ins | Various Sample Libraries

cmbourget
Member
Posts: 229
Joined: Fri Dec 28, 2012 3:47 am
Contact:

Re: Cubase 10.0.20 maintenance update

Post by cmbourget » Wed Apr 17, 2019 10:03 pm

I tried again to adapt to this new interface. Nothing to do. What sadness ... We had a nice interface with 9.5., Not perfect, a little rough (big lines began, after the names of bold and big faders), but correct. Now it's the ugliest interface in the market. Such a waste ! When we think that Dorico's interface is so professional ... Goodbye Steinberg. You had a chance to match Pro Tools first. Chance spoiled by the designers.
Cubase 10, Pro Tools 2019.5
PC Windows 10, Intel Xeon E5-2667 v2 3.30GHz, 8 cores, 64 Go
PrismSound Titan, Solo Be and Focal sub

User avatar
Steve Helstrip
Member
Posts: 780
Joined: Fri Jan 14, 2011 1:23 pm
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Steve Helstrip » Wed Apr 17, 2019 10:50 pm

I was really hoping to have our toolbox back over 2 lines. Will this ever happen? Or is this a permanent change that NO ONE asked for?
Hackintosh, 8700K / 4.8GHz, 16Gb, OSX10.14.4
MacBook Pro Retina (2015), i5, 8Gb, OSX10.14.4
Cubase Pro 10
Vienna Ensemble Pro 6
UAD-2 Octo, Focusrite Clarett Thunderbolt
Cubase user since 1989!

http://www.thethrillseekers.co.uk
http://www.twitter.com/stevehelstrip
http://www.facebook.com/thrillseekersofficial

User avatar
SF_Green
Junior Member
Posts: 158
Joined: Wed Jul 17, 2013 1:47 pm
Location: San Francisco
Contact:

Re: Cubase 10.0.20 maintenance update

Post by SF_Green » Wed Apr 17, 2019 11:29 pm

Jim B wrote:
Wed Apr 17, 2019 5:39 pm

I know Greg is doing a Google Hangout tomorrow night
Thanks for the heads up! Non-FB person here.
Cheers
Cubase Pro 10.0.40, Wavelab Elements 9.5.50, Live 10.1 Suite, Reason 10.4, SonarPt-2017.10, Finale 25, Komplete12 Ult, Omnisphere 2.6, BFD3, ARP Omni, many things with strings.
RME FireFace 800 (D 3.125, fw 2.77), Adam A7X, UAD-2 Quad, NI S88 Mk2, A-800 PRO, CC121, Alesis QS7.1, Arturia BeatStep Pro, Maschine MkII, POD HD500
AMD FX-8370, Gigabyte 990FXA-UD3, Win 10 Pro x64 v1903, 16Gb CorsairDDR3-1600
GeForce GTX 950 (436.15), SSD 525Gb (OS), SATA 3 & 1.5Tb
GrSltz My Studio

Doctor Lupo
Junior Member
Posts: 83
Joined: Thu Dec 16, 2010 12:01 am
Contact:

Re: Cubase 10.0.20 maintenance update

Post by Doctor Lupo » Thu Apr 18, 2019 1:47 am

Steve Helstrip wrote:
Wed Apr 17, 2019 10:50 pm
I was really hoping to have our toolbox back over 2 lines. Will this ever happen? Or is this a permanent change that NO ONE asked for?
Plus 1
Cubase Pro 10 64bit, H-tosh 4ghz, Yosemite latest, 32gb ram, UA Apollo Quad Fw, MOTU 828 mk2, Macbook Pro 2.4ghz, Mainstage, Digidesign 002 rack, MOTU Ultralite mk3

Padshop Pro 1.1.0.134, VSL SE, Stylus RMX, Omnisphere 2.5, Keyscape, Trilian, Ivory II, EW Play, HALion 3.5.593 (now obsolete, thanks Stberg).

Cubasis - latest

Lots of keyboards, guitars and other noisemakers.

User avatar
raino
Grand Senior Member
Posts: 3581
Joined: Tue Dec 21, 2010 2:41 am
Location: San Francisco
Contact:

Re: Cubase 10.0.20 maintenance update

Post by raino » Thu Apr 18, 2019 2:16 am

dman2014 wrote:
Wed Apr 17, 2019 8:36 pm
Only thing I've noticed since installing this on my system is that Cubase now always asks whether I want to save or not on exit, even after saving the project just before. That's a bit annoying, but rattles confidence as to why it's happening.
That has been intermittently happening to me for years now. Cubase sometimes thinks changes have occurred since saving & other times knows no changes have occurred. No pattern about when it does this that I can tell.
rodger

Cubase Pro 10.0.30, Win10 Home, Halion6, BFD3, GPO, Komplete Ultimate 9, Waves Gold, Misc. other

i7 4771 Haswell Processor 3.5GHz, ADK LGA1150, 16GB RAM, GeForce GTX970, RME Fireface 400, 2x UAD-2

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests