I need to update my Cubase but is it the right time?

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
ErikK
New Member
Posts: 6
Joined: Mon May 07, 2018 11:06 am
Contact:

I need to update my Cubase but is it the right time?

Post by ErikK »

Hey guys,

I think I have to update my Cubase 6 because my NI Kontrol is not working anymore with it. Since the 2.0 Kontrol update Cubase crashes as soon as I open a project.

I tried many things, even going back to old Kontrol versions which worked fine before but now even they wont work. Already trying to fix this for weeks and nothing seems to fix the problem. I contacted NI and even they couldn't fix the problem. In the end NI said it's my Cubase, because it's outdated which I think is a ridicules excuse!

Anyway there seems to be no solution so I have no other option then update to Cubase 9.5 but is it the right time with Cubase 10 coming soon? What does that mean for me if I update now, will I have to pay again for Cubase 10 update?

vinark
Member
Posts: 666
Joined: Wed Dec 15, 2010 5:24 pm
Contact:

Re: I need to update my Cubase but is it the right time?

Post by vinark »

I would not expect kontrol to work with 9.5 if it doesn't with 6 on the same machine (maschine :-) ). First, does standalone of kontrol work and let it rescan plugins and update database. Second try a fully clean install of Kontrol. Make sure to delete al kontrol folders everywhere.

vinark
Member
Posts: 666
Joined: Wed Dec 15, 2010 5:24 pm
Contact:

Re: I need to update my Cubase but is it the right time?

Post by vinark »

And yes you will have to pay for 10 if you update now. Only after the grace period will you get a free 10 update. Historically you will know in December.

ErikK
New Member
Posts: 6
Joined: Mon May 07, 2018 11:06 am
Contact:

Re: I need to update my Cubase but is it the right time?

Post by ErikK »

vinark wrote:
Thu Sep 27, 2018 2:52 pm
I would not expect kontrol to work with 9.5 if it doesn't with 6 on the same machine (maschine :-) ). First, does standalone of kontrol work and let it rescan plugins and update database. Second try a fully clean install of Kontrol. Make sure to delete al kontrol folders everywhere.
It does work with 9.5, I tried 9.5 trial and it worked. Kontrol standalone works with keyboard aswell, that's the only way I have been playing with the midi key for the last months. I already tried a full clean install of Kontrol several times, nothing seems to fix the problem. Cubase works just fine if the Kontrol S61 is turned off, it crashes only if I turn on Kontrol S61 and open a project, even a new empty project. I also tried to remove the Kontrol.dll from Cubase and the problem remained, it always crashed if I turn on the Kontrol S61.

vinark
Member
Posts: 666
Joined: Wed Dec 15, 2010 5:24 pm
Contact:

Re: I need to update my Cubase but is it the right time?

Post by vinark »

Ah it is the kontrol keyboard, not the software. This might be fixable. There is a way to switch if cubase uses directmusic or mme midi ports. It is different from 6 to 9.x. See if you can enable or disable the ignore portfiltering on C6. I do not remember exactly how but it is with moving a file in the cubase folder. It is not the new software but the keyboard driver that is causing the issue. You might be able to downgrade after uninstalling that driver. Not uninstalling the kontrol software. You might even be able to choose the older driver from device manager without a reinstall, by using update driver and then choose driver (click bottom options in update driver 2 times).

ErikK
New Member
Posts: 6
Joined: Mon May 07, 2018 11:06 am
Contact:

Re: I need to update my Cubase but is it the right time?

Post by ErikK »

vinark wrote:
Thu Sep 27, 2018 3:55 pm
Ah it is the kontrol keyboard, not the software. This might be fixable. There is a way to switch if cubase uses directmusic or mme midi ports. It is different from 6 to 9.x. See if you can enable or disable the ignore portfiltering on C6. I do not remember exactly how but it is with moving a file in the cubase folder. It is not the new software but the keyboard driver that is causing the issue. You might be able to downgrade after uninstalling that driver. Not uninstalling the kontrol software. You might even be able to choose the older driver from device manager without a reinstall, by using update driver and then choose driver (click bottom options in update driver 2 times).
Thank you. I have tried everything your wrote, unfortunately nothing solved the problem. Btw there is only KOMPLETE KONTROL Driver 4.2.0, didn't find any other version of the driver.

User avatar
silhouette
Senior Member
Posts: 1340
Joined: Fri Jan 14, 2011 12:45 am
Contact:

Re: I need to update my Cubase but is it the right time?

Post by silhouette »

Have you tried restoring the computer to a point before you installed the driver. That is if you have Restore enabled. I hesitate to suggest this as I do not always trust the process.

The question you have to ask yourself is do you want to be without Kontrol for two months? If the answer is no then upgrading is the only answer.
Intel core i7 5960X CPU 3.0 GHz 64bit 32 gig RAM - Windows 10 - AMD RadeonHD 7700 - RME Fireface UC - Cubase 10.5 - UAD Solo + Duo + Quad - Nektar Panorama P1 - Komplete 12 - All uhe - Adam AX7 + Adam Sub 8 - BFD3 - Alchemy - PSP - FabFilter - Fender Telecaster- Wudtone Strat - Gibson L4, 335x2,330L,175 -Ibanez PM100 - Musicman Silhouette x 3 - Warwick Thumb Bass - Kemper Profiling Amp -https://soundcloud.com/silhouette-17

ErikK
New Member
Posts: 6
Joined: Mon May 07, 2018 11:06 am
Contact:

Re: I need to update my Cubase but is it the right time?

Post by ErikK »

Problem solved with a MIDI cable. I had the my S61 keyboard connected to USB, I disconnected the USB and connected it with MIDI and it works.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 6 guests