Page 1 of 1

MAC: Disconnection from AUDIO MIDI SETUP

Posted: Tue Nov 05, 2019 3:38 am
by dswab
Hi there,
I just purchased the UR22C. I'm trying to get it working. If I restart the computer, and then plug in the interface, the device shows up in the audio midi setup and is selectable for both audio input and output.

If I try to start any pre-existing DAW I have, the device just disappears. Why?

I've tried Logic Pro and also Ableton Live.

I don't have Cubase, and I'm not sure I want to learn, but something tells me this is not the issue.

I've got Mac OS 10.14. The firmware is up to date. The device works for both audio input/output on simple desktop applications (spotify).

What is going on here? Any help please??

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Tue Nov 05, 2019 5:15 pm
by dswab
Update: I've updated the Mac OS to Catalina, and problem solved. *shrug*

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Fri Dec 20, 2019 3:53 pm
by LeXXt
Hello, I have exactly the same problem.

I am using my UR22C together with my Windows Laptop and FL.

Now I bought an iMac Mini 2018 and want to use it together with FL and Logic Pro X.

At first, It worked fine, I could play back e.g. on youtube.

Also my Soundcard was detected by FL Studio on Mac.

When I then downloaded Logic X Pro, and tried afterwards to restart FL (after heaving restarted the system).

The sound card gets 'lost'. I will have to remove it from the USB, then plug it in again.
It is recognised again, however, only if I do not open one of my 2 DAWs (see above). Then, the connection will be lost again.

I already have the newest Catalina and installed the drivers.

What can I do?
It doesn't work on USB 2.0 mode either.

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Mon Dec 23, 2019 8:15 pm
by sjmusso1
I have the same issue with my UR44C. Steinberg support is aware of the issue as I have spoken to several people. At this point it has been escalated to Germany. When you first boot up, it works fine. However, if you launch anything that uses it (Cubase, etc.), it disappears. SJ

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Mon Dec 30, 2019 3:22 pm
by Ed Doll
Are you aware of this article?
https://helpcenter.steinberg.de/hc/en-u ... n-Hardware

A more general approach can be found in the article by Apple:
https://developer.apple.com/library/arc ... index.html

It is important to know that the option to change the setting disappears 30 minutes into the session so a reboot might be needed to allow you to change the setting.

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Thu Jan 02, 2020 7:41 pm
by sjmusso1
That didn't fix it, but the newly released USB driver did! Thanks.

Re: MAC: Disconnection from AUDIO MIDI SETUP

Posted: Sat Jan 11, 2020 8:42 pm
by Norfolk Hall
I am having exactly the same issues. Please can you provide a link to the new USB Driver ?

Many thanks.