Page 1 of 1

Unwanted Auto-Merge of MIDI Events from Different Tracks

Posted: Tue Oct 08, 2019 1:43 pm
by RenTenTen
Hi, the issue below drives me nuts currently.

My issue:
Cubase for some reason sometimes automatically merges Midi events from different tracks and equal length together and I cannot for the life of me find a way to separate those events - or prevent them from merging automatically in the first place. The more midi events of equal length I add on other tracks at the same position, the more of them get merged, even if they have different content.

In the attachment you'll find a screenshot of the merged midi events from different tracks, which I can't seem to separate.

What I've tried:
- looked through various Midi options/commands in the options menu and Shortcut list, nothing so far that would solve it
- looked through forums, googled the crap out of it, unfortunately I can't find similar problems online
- 'dissolve' options, snapping, anything that I thought might be related, without success

Help would be much appreciated!
Kind regards,
Philipp

Re: Unwanted Auto-Merge of MIDI Events from Different Tracks

Posted: Tue Oct 22, 2019 10:43 am
by Martin.Jirsak
Hi,

If you record, the MIDI Parts are always snapped to the Bars. Isn't this the case? You can disable this in the Preferences > Record > MIDI > Snap MIDI Parts and Bars.

Re: Unwanted Auto-Merge of MIDI Events from Different Tracks

Posted: Fri Oct 25, 2019 8:39 am
by RenTenTen
Hey, thanks for your reply, unfortunately I think the usual horizontal bar snapping is not related to my problem.
I've tried your suggestion, it didn't solve me issue though.

I've recorded a video in the following Google Drive link:
https://drive.google.com/open?id=1lbQyL ... fmVXZrzCKj

Please don't get confused by the fact that the recording does not fluently show the movement of midi items, snapping is not the issue here.
You can see that there is midi parts vertically merged together. I just can't separate them, even if they have different content.

Later on in the video I will show how this issue emerged, by copy-pasting midi parts vertically. As soon as I click the upper part (original) - without holding CTRL/CMD or anything - it automatically selects the copied midi part PLUS the part being copied. From there on they are bound together, non-separable. At least I have not found a way to separate them yet.

Since I have some other projects in which I copied stuff and it merged together, it's kind of a big issue for me.
Any help much appreciated. If you have any further questions or need another recording to show things differently, let me know.

Re: Unwanted Auto-Merge of MIDI Events from Different Tracks

Posted: Fri Oct 25, 2019 10:32 am
by Martin.Jirsak
Hi,

I see, now I understand your problem.

The problem is, the MIDI Tracks are in the Folder track, where is Group editing enabled. Disable it.

Re: Unwanted Auto-Merge of MIDI Events from Different Tracks

Posted: Mon Oct 28, 2019 8:33 am
by RenTenTen
Yes, that was it.

Thanks a lot, Martin!
I've never worked with the group track function before, so I wasn't even aware it was enabled.