Cannot add video (MP4) in Cubase 9.5.41 (SOLVED)

Use this forum for an overview of issues and to report new ones.
Post Reply
User avatar
ANeeman
Member
Posts: 371
Joined: Sat Dec 31, 2016 8:30 am
Location: Latvia
Contact:

Cannot add video (MP4) in Cubase 9.5.41 (SOLVED)

Post by ANeeman »

Hi!
Updated to 9.5.41 and now cannot add MP4 video file to empty project. Tried to add video track first, the same. Tried to import to Pool, the same - Open window tells - "Invalid or not supported file!". Tried to do the same in Cubase 9.0.40, the same. Nothing installed or uninstalled except update to Cubase 9.5.41.

Please, help! I need to compose music for two video projects right now! Today!!!
Last edited by ANeeman on Thu Nov 08, 2018 6:34 pm, edited 1 time in total.
Cubase Pro 10.5, WaveLab Pro 10.0, Dorico Elements 3.5, HALion 6, HSO, KOMPLETE 12 U CE, Spitfire Albion ONE
UR242, MG10XU, MG12XU, CS1x, M-Audio Oxygene-25.
Windows 10 Pro, 3.4 GHz, 16 GB.
Albums: Presence (2019) | Millectrinium (2018) | Nature. Water (2017) | Oracle (2017) | Two. Midnight Talks (2015)

Larioso
Member
Posts: 596
Joined: Mon Aug 04, 2014 9:18 am
Location: Sweden
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41

Post by Larioso »

If to guess MP4 is just a container and can hold many encoded types. H264 worked for me at least, within MP4.
I also tried MOV with H264 inside, also works.

If in a rush - this works really well, and much, much lower cpu than Cubase new video engine:
http://vidplayvst.com/downloads.htm

I even prefer it. Save 20% cpu using that instead.

Load VST into track instrument and videofile, set size on any screen you have and run transport. If needing to start playing som bars into a project - place a 'C' note somewhere and check that options.
Windows 7 Pro - Intel i7-860 2.8GHz 16 GB - Cubase Pro 9.5 latest - RME HDSP 9632 + AI4S + Audient ASP 800 - Nvidia GT730

User avatar
ANeeman
Member
Posts: 371
Joined: Sat Dec 31, 2016 8:30 am
Location: Latvia
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41

Post by ANeeman »

Do I need to install additional software? I don't think so. The VLC player still plays the same MP4 files as it was before, only Cubase somehow don't accept any video file.
Cubase Pro 10.5, WaveLab Pro 10.0, Dorico Elements 3.5, HALion 6, HSO, KOMPLETE 12 U CE, Spitfire Albion ONE
UR242, MG10XU, MG12XU, CS1x, M-Audio Oxygene-25.
Windows 10 Pro, 3.4 GHz, 16 GB.
Albums: Presence (2019) | Millectrinium (2018) | Nature. Water (2017) | Oracle (2017) | Two. Midnight Talks (2015)

Larioso
Member
Posts: 596
Joined: Mon Aug 04, 2014 9:18 am
Location: Sweden
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41

Post by Larioso »

Look in properties in VLC and see what it says about codec. H264 should be ok in Cubase, not sure which formats are ok - check manual/specs on that.

Steinberg manual just refer to their site - here:
https://helpcenter.steinberg.de/hc/en-u ... and-Dorico

Reaper as one, you can use VLC as monitor application for video - not sure how to do that in Cubase with external monitor.

More software needed - it depends on your method of working, if to edit anything - if absolutely need to write back final audio into the same video etc.
There is an addon for vidplayvst that writes audio back as well.

But I just use a video editor like Powerdirector for that part - only do an audio track that is rendered in Cubase, and import into video editor.
Windows 7 Pro - Intel i7-860 2.8GHz 16 GB - Cubase Pro 9.5 latest - RME HDSP 9632 + AI4S + Audient ASP 800 - Nvidia GT730

User avatar
ANeeman
Member
Posts: 371
Joined: Sat Dec 31, 2016 8:30 am
Location: Latvia
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41

Post by ANeeman »

Almost 4 hours was lost to find the solution. I uninstalled K-Lite, installed another codecs pack, uninstall it, restart sytem, then clean it and now use default windows codecs and nothing helps. Then I realise that somehow Sony Vegas on importing video MP4 sets the frame rate to 25.87. I composed the video and then rendered it with project settings, of course - 25.87 fps and Cubase didn't recognize it (strange in this century*). Now I set fps to 25 in project and render again. Now Cubase is allowing to import it.

Maybe somehow Steinberg's developers can add some messages to import Open window that not format is illegal, but framerate?

*Strange in this century is that big systems can convert video fps from 25 to 30, 30 to 29 and 29 to 25 almost on the fly, but cannot recognize 25.87 and convert while importing. The container H264 is the same all the time. Strange! There is no hardware engine that converts 25 to 30 automatically. All is done programmatically. So why these numbers 25/29/30 are hardcoded? Really strange. As programmer I don't understand it.

VLC player plays 25.87 fps correctly while Cubase told - illegal format.
Last edited by ANeeman on Thu Nov 08, 2018 8:52 pm, edited 2 times in total.
Cubase Pro 10.5, WaveLab Pro 10.0, Dorico Elements 3.5, HALion 6, HSO, KOMPLETE 12 U CE, Spitfire Albion ONE
UR242, MG10XU, MG12XU, CS1x, M-Audio Oxygene-25.
Windows 10 Pro, 3.4 GHz, 16 GB.
Albums: Presence (2019) | Millectrinium (2018) | Nature. Water (2017) | Oracle (2017) | Two. Midnight Talks (2015)

Larioso
Member
Posts: 596
Joined: Mon Aug 04, 2014 9:18 am
Location: Sweden
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41 (SOLVED)

Post by Larioso »

I don't think I ever saw 25.87 fps as an option, TBH.
29.97 and such, 23.97 I think too - or I never looked for it.

I guess syncing audio is a dilemma, if that is where it matters to a mediaplayer.

And yes agree, Steinberg could throw in some relevant messages to you - so you know why it denied accepting it.

Not the
- Computer says no

kind of thing. :D
Windows 7 Pro - Intel i7-860 2.8GHz 16 GB - Cubase Pro 9.5 latest - RME HDSP 9632 + AI4S + Audient ASP 800 - Nvidia GT730

-steve-
External Moderator
Posts: 9670
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41 (SOLVED)

Post by -steve- »

independent manufacturer rep (not a Steinberg employee)
[safe mode] [cubase manual] [score editor manual]

User avatar
ANeeman
Member
Posts: 371
Joined: Sat Dec 31, 2016 8:30 am
Location: Latvia
Contact:

Re: Cannot add video (MP4) in Cubase 9.5.41 (SOLVED)

Post by ANeeman »

@-steve- Thank you!
I know - RTFM is the last chance, but should be the first :)
But in my case I did not notice that there can be something between 25 and 29.97. Sony accepts any value, but Cubase's policy is stright to predefined. Now I know.
Cubase Pro 10.5, WaveLab Pro 10.0, Dorico Elements 3.5, HALion 6, HSO, KOMPLETE 12 U CE, Spitfire Albion ONE
UR242, MG10XU, MG12XU, CS1x, M-Audio Oxygene-25.
Windows 10 Pro, 3.4 GHz, 16 GB.
Albums: Presence (2019) | Millectrinium (2018) | Nature. Water (2017) | Oracle (2017) | Two. Midnight Talks (2015)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 3 guests