Midi timing problem

Use this forum for an overview of issues and to report new ones.
Post Reply
ha33y
Junior Member
Posts: 108
Joined: Sat Apr 16, 2016 11:20 am
Contact:

Midi timing problem

Post by ha33y » Mon Sep 24, 2018 9:27 pm

Hi all,
I am on Cubase 9.5 Pro, Windows 7 x64 using Keystation 61 USB as mother keys controller. No outboard gear all in the the box. Using Behringer Xenyx 1204 USB as my mixer/audio device. Everything works well however when recording a midi part for example a small solo sax or guitar or something else from one of my plugins, (by the way no latency issues) so I record the 4 bar part then play it back and it is slightly out and in, just kind wavers about (only slightly ) but enough to hear it's not as I played it, a little in front of the beat in places. So I play it again, slowing down my playing a bit, then play it back and it is still very very slightly in front in sections. It's making me think that I play it like that but I don't !
The Auto Quantize is OFF and there is no other Quantize (that I know of) which is working in the background.
This is so crazy.
I have checked and unchecked the 'System Timestamp' but it's the same.
Can't think of anything else that would effect my midi like that.
Anyone experienced this before? If so and you found the culprit I would surely appreciate your advise on getting this to behave itself and play back exactly what I recorded.

Thanks in advance.

yinonyahel
Junior Member
Posts: 129
Joined: Wed Jun 27, 2012 10:25 pm
Contact:

Re: Midi timing problem

Post by yinonyahel » Thu Sep 27, 2018 10:07 am

i just re-install with cubase 9.5 on mac pro , have the same issue . would love to hear any solution to this matter , thanks
Cubase 8.52 , Mac pro , Orion 32+ , UAD Satelite octo , Moog , Rolands , Korg Kronos , Virus , Prophet , Neuman , Blue button , SSL , M1 , V76 and more ...

ha33y
Junior Member
Posts: 108
Joined: Sat Apr 16, 2016 11:20 am
Contact:

Re: Midi timing problem

Post by ha33y » Sun Sep 30, 2018 5:39 pm

hmm, obviously we must be the only 2 people on the planet who experience this...

Accel0001
Junior Member
Posts: 112
Joined: Mon May 11, 2015 6:32 am

Re: Midi timing problem

Post by Accel0001 » Sun Sep 30, 2018 11:38 pm

"ASIO Latency Compensation"?

Recording>MIDI Recording Specifics>Recording MIDI
https://steinberg.help/cubase_pro_artis ... idi_c.html
If you perform a live recording on a VST instrument, you usually compensate the latency of the audio card by playing earlier.
In consequence, the timestamps are recorded too early.
If you activate ASIO Latency Compensation on the track list, all recorded events are moved by the current latency setting.
Preferences>Record>Record - MIDI>ASIO Latency Compensation Active by Default
https://steinberg.help/cubase_pro_artis ... idi_r.html

MIDI Track Controls
https://steinberg.help/cubase_pro_artis ... ols_r.html
Instrument Track Controls
https://steinberg.help/cubase_pro_artis ... ols_r.html
Sampler Track Controls
https://steinberg.help/cubase_pro_artis ... ols_r.html
DAW: Cubase 10.0.50 (6.5 - 10), FL Studio 20.6 (8 - 20.6), Ableton Live 10 (8-10), Reaper, Studio One, etc.
PC: Win7 Ultimate, i7 3930K 4.2GHz (OC), 32GB RAM

Nano101
New Member
Posts: 1
Joined: Sun Jan 13, 2019 10:47 pm
Contact:

Re: Midi timing problem

Post by Nano101 » Sun Jan 13, 2019 10:52 pm

The solution for this problem is the following :
1- Go to Transport->Midi Cycle Record Mode -> uncheck (Auto quantize in Record)
2- Play again
3- It's done

Drewcipher
New Member
Posts: 9
Joined: Wed May 09, 2018 9:59 pm
Contact:

Re: Midi timing problem

Post by Drewcipher » Sat Feb 02, 2019 2:04 am

Also having the same issue. Been having this problem since Cubase 3!! I can't believe they haven't fixed this yet. Ugh.
--
Cubase 10.0.15, Win7 Ultimate (64 bit), i7-6700 3.4 GHz, 32 GB RAM

Drewcipher
New Member
Posts: 9
Joined: Wed May 09, 2018 9:59 pm
Contact:

Re: Midi timing problem

Post by Drewcipher » Sat Feb 02, 2019 2:40 am

Figured this out FINALLY! None of the above suggestions worked, but what DID work was:

Studio -> Studio Setup -> VST Audio System
Then set ASIO Guard Level to "Low"

Cleared the issue as well as an annoyingly high latency level despite a super small buffer size on my audio interface.
--
Cubase 10.0.15, Win7 Ultimate (64 bit), i7-6700 3.4 GHz, 32 GB RAM

archetek
New Member
Posts: 12
Joined: Wed Oct 01, 2014 6:41 pm
Contact:

Re: Midi timing problem

Post by archetek » Thu Mar 28, 2019 8:12 pm

I've been having this issue for years. On Cubase 8 atm.

Does Steinberg really not care that their DAW can't record midi notes correctly?

Every single other DAW I own can do this without any problems. It is seriously baffling that they've allowed this to continue for so long. I've tried every fix in this thread, and every fix in every other thread, and no matter what I do all midi notes get inserted EARLY. Sometimes it's almost a full 16th note early!!

I've already purchased Live 10, and will likely stop using Cubase altogether over the next year if they really can't be arsed to make this work properly.

Jim Clark
Junior Member
Posts: 66
Joined: Wed Dec 15, 2010 6:40 pm
Contact:

Re: Midi timing problem

Post by Jim Clark » Sun Dec 01, 2019 7:38 pm

I'm on Nuendo 10 so not sure this will apply, but I had the same issue with MIDI notes being shifted noticeably forward after recording.
The fix for me was found in studio/studio setup/MIDI Port Setup. I checked the box marked "Use System Timestamp for "Direct Music" Inputs and for me, this solved the problem.

Nex
New Member
Posts: 1
Joined: Wed Dec 04, 2019 5:39 am
Contact:

Re: Midi timing problem

Post by Nex » Wed Dec 04, 2019 5:51 am

Same issue. My fix was having only one device active in MIDI port setup. The one using DirectMusic. Make the others inactive. Also, place check mark on Use Device ‘DirectMusic’ and Use System Timestamp for ‘DirectMusic’. Hope it helps, good luck!

aricastudio
Junior Member
Posts: 67
Joined: Fri Jun 22, 2012 3:29 pm
Contact:

Re: Midi timing problem

Post by aricastudio » Tue Dec 31, 2019 7:42 pm

I also started having Midi Timing Issues when I updated from Cubase Pro 9.5 to Cubase 10 and still with Cubase 10.5. Windows 10, latest updates, MOTU MTP AV USB Interface with their latest driver. Midi simply chokes and notes do not sound and then they resumes. No matter if it is a Midi track with notes on it or simply playing with Monitoring On and Cubase stopped. Never had this happen in Cubase before. Very, very annoying.

hArSHNess
New Member
Posts: 1
Joined: Wed Jan 15, 2020 3:31 pm
Contact:

Re: Midi timing problem

Post by hArSHNess » Wed Jan 15, 2020 3:44 pm

In my experiences Developping VST efx ,
They dont use exact timing info about MIDI event within AudioBuffer.(=delta frame info)
All delta info is Zero , using Cubase as host !
(so maybe MIDI events like playing keyboard are push forward as Ha33y experienced)

But I checked StudioOne , delta frame info is propery stored !

then, I got great respect for presonus good job !

It is so strange , origin of VST didnt use their defined specification .
I heard that from Cubase SX , they didnt use delta frame info.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest