Set Device Attenuation to 0 db should be OFF by default

Post questions and find answers on our latest WaveLab releases here.
Post Reply
rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Wed Apr 18, 2018 4:47 pm

Set Device Attenuation to 0 db should be OFF by default.

I was trying out Wavelab Pro and nearly had my eardrums blown out from the sudden increase in volume because Set Device Attenuation to 0 db was on. Luckily I remembered this absurdity from Dorico which shares the same audio engine and did the same thing to me some months ago.

Steinberg, this is stupid and you will end up in court one day with a lawsuit from somebody who has had their ears permanently damaged by this setting. What's more, the toggle to turn it off is relatively hidden in the preferences.

As it stands, everytime you change or do something, it sets the volume on my Apogee Quartet to 0 - my normal listening level is -42.

I am sure someone thought they had a good reason for setting it on by default, but it is dangerous and needs to be fixed.

PG
Moderator
Posts: 6377
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by PG » Wed Apr 18, 2018 6:11 pm

I don't see what option you mean. Where in WaveLab?
Philippe

Romantique Tp
External Moderator
Posts: 3015
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by Romantique Tp » Wed Apr 18, 2018 6:13 pm

It's a CoreAudio thing. You have to open Audio Connections and then open the Control Panel for the audio device, I think.
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

PG
Moderator
Posts: 6377
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by PG » Wed Apr 18, 2018 10:19 pm

WaveLab does not alter CoreAudio settings. This is a system user setting.
Philippe

rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Thu Apr 19, 2018 9:21 am

Hi Phillipe,

1) You reach the option by going to Preferences/Audio Device control Panel/CoreAudio Device Settings

2) Wavelab (and Dorico) clearly ARE altering these settings otherwise there wouldn't be an option, and what's more it is resetting the Device Attenuation every time you take certain actions like coming back to the software unless you turn the option off.

I use Logic, Soundforge, Reaktor, Final Cut Pro and a good few other programmes that use the CoreAudio interface on my Mac, and not one of them does this - ever.

iMac 2013
MacOS High Sierra
Apogee Quartet

User avatar
Thomas W. Bethel
Member
Posts: 416
Joined: Wed Dec 15, 2010 9:43 pm
Location: Oberlin, OH
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by Thomas W. Bethel » Thu Apr 19, 2018 11:30 am

No problems here with my RME card. Must be a Apogee problem.
Thomas W. Bethel
Managing Director
Acoustik Musik, Ltd.
Room With a View Productions
http://www.acoustikmusik.com/

Doing what you love is freedom.
Loving what you do is happiness.

Celebrating 23 years in business in 2018

Rat
Member
Posts: 592
Joined: Thu Dec 16, 2010 6:33 am
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by Rat » Thu Apr 19, 2018 11:39 am

I do not run a Quartet but I understand that this is an Apogee issue that goes back some years and, as PG says, nothing to do with WL.

See here for example (volume resets automatically after Yosemite 2014): https://discussions.apple.com/thread/6614166

The fix seems to be a firmware update.
Regards

Paul

https://www.facebook.com/paul.blakey.5

Windows 10 Professional (x64), Intel Core i7 7700 Quad Core LGA 1151 3.6 GHz CPU, 32 GB RAM, Gigabyte Z270M-D3H LGA 1151 mATX Motherboard, 2 x Intel Pro 5400S Series 256GB SSD (system and session drives), RME HDSPe AIO, Mytek converters

WaveLab 9.5 Pro current release, ProTools, iLok, DMG (Dave Gamble), Sony Oxford, Weiss, Class A Solid State and Custom Stuff

rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Thu Apr 19, 2018 12:27 pm

I have no issue with being wrong, and I have sent an email to Apogee asking them to comment - but:

I am running MacOS High Sierra and the latest firmware on my Quartet - it was updated about a month ago.

Searching on Google brings up a number of results of others experiencing the same thing - one with an Apogee Duet, but this from someone with an MOTU card (see below)

However - none of this addresses the issue which is: this setting can seriously damage your hearing, even if it is confined to Apogee and perhaps MOTU and possibly other hardware users. Nobody is saying that it is deliberate, but having being made aware of the problem, do something about it. We are all musicians and do you really want to be responsible for bursting another musician's eardrums, even if it is not your fault or responsibility?

How is the next Apogee owner who buys Steinberg software going to know about this issue until it is too late?

Even Paul Walmsley in a response to the postbelow says:

However, this can catch you out if you are not used to this of workflow. which is exactly what happened to me and the woman below.

Also - there is no response to the fact that it is only the Steinberg Audio engine that causes this issue - Logic, NI, Soundforge etc. do not do this - why?

Make the default OFF and put a note in the manual about this setting - at the moment there is no mention of this setting at all as far as I can see. Professional studios will find the setting and turn it on if they need it for level matching. The rest of us can then use Steinberg software without being paranoid about having our hearing damaged.

Unread post by harmonica » Fri Aug 11, 2017 8:45 am

Hello

I'm using Dorico 1.1 on a Mac with a Motu soundcard (an Ultralite mk 3).

During the working day I often have other audio software running. Quite a few times, I've opened Dorico while sound is playing via other software and been knocked out of my seat as Dorico ignores my audio settings and forces the volume up to maximum (sometimes 40dB higher than I'm currently working). This happens when I open Dorico itself. If I then bring the volume down again, it happens again when I open a Dorico score.

Is there a way to fix this?

I do need to keep other audio files running when working in Dorico - if there was a way to open Dorico and close it, like other audio software, it would be much easier to integrate it into the working day.

Thanks
Sarah

Paul Walmsley answered: (with an explanation of why the option is there in the first place)

The reason for this is that Dorico uses Cubase's pro audio engine, and the default setting for the audio engine is that if you set the output fader to 0dB, then the sound card output is at 0dB. This is very important in a professional context because you need to rely on the levels. Also in a professional context you never have the soundcard output connected directly to the speakers without some kind of volume control.

However, this can catch you out if you are not used to this of workflow. Fortunately there is an option: In Dorico / Preferences / Audio Device Setup press the Device Control Panel button and untick the option to 'Set Device Attenuation to 0dB'. This is something that you should only need to do once and then and the setting is remembered for future sessions.

bob99
Senior Member
Posts: 2255
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by bob99 » Thu Apr 19, 2018 6:44 pm


rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Fri Apr 20, 2018 9:16 am

Hi Bob,

Yes it is - so it is clearly not just an Apogee issue, but affecting RME and MOTU users too and probably other hardware makes as well. I'm really surprised to see that someone posted about this issue in 2011 and it is still not addressed in 2018.

S-EH
Member
Posts: 317
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by S-EH » Fri Apr 20, 2018 12:30 pm

Hi,

Yes this is an old thing but has bite me! I had the RME Fireface 800 from 2004 !!!
but this is a CoreAudio settings/Control Panel and I agree it could be off by default
and been high lighted in the manual to protect ears, musicians, producers, speakers e.t.c
same thing in Cubase and WaveLab

regards S-EH
RME Fireface 800, WaveLab, Cubase...

bob99
Senior Member
Posts: 2255
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by bob99 » Fri Apr 20, 2018 6:34 pm

I can't even find a similar setting in Windows audio. Is there one?

rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Sun Apr 22, 2018 10:11 am

Hi Bob,

Not sure, but I think it is a MAC only issue

bob99
Senior Member
Posts: 2255
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by bob99 » Sun Apr 22, 2018 7:40 pm

Does it happen with Pro Tools, Studio One, Reaper?

Leaving out Apple products like Logic and FCP for now, if it only happens with Steinberg programs it seems to me it would be a valid complaint in 2018 with more smaller portable type installations. Does that seem wrong?

Does anyone think it's something Apple should "fix" in Core Audio? And would that cover enough existing systems?

rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Sun Apr 22, 2018 9:08 pm

Hi Bob,

In my experience, it is only with Steinberg software - I am not a Cubase user, but I am a registered user of both Dorico and Wavelab and they both suffer from this problem.

Apart from Apple products, I also use Native Instrument software - Reaktor and Komplete, and Soundforge, formerly a Sony product but now owned by Magix. Also Audacity on occasion, and some standalone apps like Celemony Melodyne, IRCAM software etc.

None of these have the option in their audio setups and none have ever caused this problem.

User avatar
Justin P
Senior Member
Posts: 2121
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by Justin P » Fri May 11, 2018 2:26 am

I'm not sure where this issue is at but did you try to deactivate this setting in the WaveLab preferences?

See attachment.
Attachments
Screen Shot 2018-05-10 at 8.24.00 PM.png
(201.43 KiB) Not downloaded yet
http://www.mysteryroommastering.com/http://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.13.4

rgonski
New Member
Posts: 22
Joined: Tue Feb 21, 2017 10:13 pm
Contact:

Re: Set Device Attenuation to 0 db should be OFF by default

Post by rgonski » Fri May 11, 2018 9:34 am

Hi Justin,

Yes I did, and that solves the issue. But the problem is that until you get your ears blasted for the first (or second or third) time, you don't know or understand what the problem is, or that the setting actually exists - once the penny drops and you change the setting all is well - but that is too late. Which is why I suggested making the default setting off as a protection against someone getting their ears damaged, and letting pro users who have a calibrated setup turn it on if they wish to do so.

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 2 guests