X99 USB Issues

Use this forum for an overview of collected issues and to report new ones.
Post Reply
reziduchamp
New Member
Posts: 16
Joined: Mon Nov 21, 2016 3:03 pm
Contact:

X99 USB Issues

Post by reziduchamp » Sun Aug 13, 2017 7:14 pm

Does anybody have a solid X99 system (preferably X99A-ii) that actually works with a USB soundcard? What are your BIOS settings? Anyone who has a working system seems to be using either PCIe, Thunderbolt or Firewire, which explains why they don't have my issues with spikes in Cubase and I'm 100% certain its related to USB on the X99.

1. Novation Launchkey has random errors, such as random buttons lighting up, key dropouts (even on Bitwig demo on Linux) and sometimes the driver totally drops off from Cubase and Ableton, whilst its still recognised in Device Manager - it needs reinstalling or a reboot when that happens.
2. Audient ID14 has dropouts and under Cubase I get 100% spikes when tracks are only at 20% in Average Load. Also get a random box that pops up, which looks like the radio buttons to choose your device driver - Bog standard ASIO or ID14 driver. This sometimes happens for a fraction of a second whilst getting 100% audio spikes and audio dropouts.
3. Mouse delays, sometimes it can be impossible to use for a few minutes. This can be made worse by plugging a USB3 SanDisk into the front panel USB3 ports. Logitech M235 and 185 and a Genius wired mouse, all produce lag. Plugging it in can sometimes cause the mouse to lag for 2-3 minutes and I've even had to remove it to get the mouse back.
4. Novation update software hangs when updating via the X99 USB. Updates perfectly using my old i7 870. No errors on the old board and no audio spikes. Exactly the same Cubase setup. 8.5.30.
5. Swapped NVidia 730 for a Radeon 230 R5 and only installed basic drivers. Graphics isn't the culprit.
6. Errors don't show up in Event Viewer. I got a 100% spike last night and there was nothing in there, so its not related to software.
7. Errors can happen when installing Windows and even under Linux. Mouse delay can sometimes be simulated but its too random to ask it to misbehave in a shop.
8. Removing USB3 (xHCI) and disabling all the USB3 and 3.1 ports hasn't helped. ASMedia is disabled as well so I only have 6 basic USB2 ports. Swapped all the handoffs etc and followed various bits of advice on this forum and got nowhere.
9. Changed all system settings USB Selective Suspend etc to disabled etc.
10. Audio spikes in Cubase get worse the more CPU I am using. Some tracks that are in early production don't seem to spike very often, but those at around 50% Average Load will spike much more often. I'm guessing they are polling the USB a bit harder.

I have even managed to simulate the error on a new install with 3 Retrologues running in Cubase and "Free Device Monitoring Studio" analysing the USB bus, although I haven't a clue what I'm doing with that. The whole system has slowed down whilst its running. Average Load in Cubase is at 0%-3% and Real-Time Peak is about 4% but it has still managed to spike to 100%.

I tried taking it back to Scan yesterday to show them the faults and of course I couldn't replicate anything just using the USB3 SanDisk, which I can usually force a fail with. After cycling 70 miles I spent about 2 hours in Tech Support with them running tests on the CPU, RAM, Hard Disks and other random issues that have no bearing on the USB faults, until I asked if they had anything to test the USB and was told that they don't test that, which begs the question why bother stress testing things like the RAM and Hard Disks to make the USB fail? The fact that they couldn't produce any faults by stressing everything else and that nothing is showing up in Event Viewer, further proves that it is a USB error and it is not software, graphics or any other issues.

These spikes don't happen in my i7-870 old motherboard, I just run out of power in that system. I can get right up to 90% before it starts red lining and the audio spikes are different with that. on the X99 it sounds like a fridge turning off and affecting the whole power loop in the room, but I've had these spikes when the fridge is doing nothing, so that is ruled out as the culprit.
Cubase 8.5.30 64bit
Windows 10 64bit
Fractal Design Define R4
Dark Rock 3
Intel 6800K
Asus X99-Aii
16gb Vengeance 2400
NVidia GT-730
Audient ID14
Novation Launchkey 49
Dual IIyama Monitors 1920x1080

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests