Page 1 of 1

Cubase 8.5 NEEDS ANOTHER UPDATE!

Posted: Wed Jul 19, 2017 9:09 pm
by ResonantMind
It's not acceptable. So much stuff is not compatible with Cubase 9, like Novation Automap. We need a stable version prior to 9.

Please release another update! On windows 10, i'm getting all sorts of crashes and instability that I didn't have on Windows 7.

Re: Cubase 8.5 NEEDS ANOTHER UPDATE!

Posted: Wed Jul 19, 2017 9:15 pm
by ResonantMind
Like F**** stop F****ING us around!

Re: Cubase 8.5 NEEDS ANOTHER UPDATE!

Posted: Thu Jul 20, 2017 12:47 am
by ResonantMind
I've always defended Steinberg/Cubase, but I'm getting *quiz*. Stabilize 8/8.5! We need a stable legacy version before the current 9.

Not even stabilize, like, f****king add features that should exist. Make it solid. Many of us have many projects on 8.. 8.5. It took me a long time to transfer my projects from 4 to 8. I don't want to have to do this all over again and revise my setup for 9 yet. I need to complete my current s*!t.

You're bs is having an effect on my livelihood. f**cking figure it out or you're losing a dedicated supporter.