Page 1 of 1

Disk Installation Problems

Posted: Sat Jul 02, 2011 7:09 pm
by Betamac
I've bought a new seagate barracuda drive

its connected to power and sata inside my machine

I hear it whizzing round, but been into 'disk management' and its not there, looked in bios and it wasn't there

Is there something obvious i'm missing here

when fisrt installed it and powered up, window told me it was installing device software, but other than that its not being seen by my computer

please help if anyone knows what Ive not done right

Is the drive faulty?

Re: Disk Installation Problems

Posted: Sat Jul 02, 2011 8:26 pm
by ray
Did you try in Disk management: Action => Rescan Disks?
Another thing to try: If your motherboard comes with 2 sata Controllers try it on the other controller.
(I had a SATA plextor DVD not being recognized until I moved it to the other controller)

Maybe try the 1.5Gbps jumper on your HD

Hope it helps

Re: Disk Installation Problems

Posted: Sat Jul 02, 2011 9:11 pm
by Betamac
thanks ray tried all that

it did show promise when i connected to a different sata socket on reboot

but as i told system to format it it lost the connection and failed

i think theres something wrong with the disk

it makes about 10 ticking sounds when first power up the computer? surely this isnt normal ?

Re: Disk Installation Problems

Posted: Sat Jul 02, 2011 10:17 pm
by Patanjali
Return it!

Re: Disk Installation Problems

Posted: Sun Jul 03, 2011 1:41 pm
by ray
Yes the clicking sound is not good: also referred to as "Click of death"
As Patanjali advised, return it.

Re: Disk Installation Problems

Posted: Sun Jul 03, 2011 7:18 pm
by Betamac
Thanks guys